May 12, 2021
by MaDOS

Veil Core mandatory wallet update v1.2.1 is now available

It is strongly recommended to update to this mandatory wallet version ASAP, and not to wait until the protocol enforcement fork on May 16, 2021.

We found a vulnerability while testing the v1.1.3 release. This vulnerability is resolved with version v1.2.1.

Veil Core wallet v1.2.1 is a mandatory update that will enforce the new protocol on Sunday, May 16, 2021 4:00 PM GMT. If certain conditions occur, a fork could happen anytime between block 1,212,090 and the protocol enforcement fork date.

We strongly recommend updating as soon as possible and not wait until the protocol enforcement fork. After the fork, the veil-project GitHub repo will be updated with the v1.2 source code. Please refrain from trading on exchanges that have not updated to v1.2.1.

Download Veil Core wallet v1.2.1 and read the full release notes here. Check our Veil support article for how to update your Veil wallet.

Still need assistance? Join the Veil community on Discord!

Share